Reply To: BP 4.2.0 for linux: Unable to translate

homepage Forums BridgePoint/xtUML Usage and Training BP 4.2.0 for linux: Unable to translate Reply To: BP 4.2.0 for linux: Unable to translate

#1987
cley95
Participant

There is no error in the post-install section of log file.

I tried creating a simple xtUML project as you described. There is still the problem.
[code title=””]home/cley/MentorGraphics/BridgePoint-420/eclipse_extensions/BridgePoint/eclipse/plugins/com.mentor.nucleus.bp.mc.c.binary_4.2.0//mc3020/bin/mcmc: 1: /home/cley/MentorGraphics/BridgePoint-420/eclipse_extensions/BridgePoint/eclipse/plugins/com.mentor.nucleus.bp.mc.c.binary_4.2.0//mc3020/bin/mcmc: Syntax error: “(” unexpected
[/code]
It seems the problem comes from the executable mcmc.

After checking again, now I probably know where the problem is, but haven’t verified my thought yet.
From my previous post,
[code title=””]mcmc: ELF 64-bit LSB executable, x86-64, version 1 (SYSV), dynamically linked (uses shared libs), for GNU/Linux 2.6.9, not stripped [/code]
The mcmc is a 64-bit executable. But my OS is a 32-bit Ubuntu (Sorry for forgetting to state this in my inital post). That may be the syntax error came from.

I download the installation package from BridgePoint for Liunx. There is no any clue of that it is for 32 or 64-bit system. :(

  • This reply was modified 5 years, 10 months ago by cley95.