Tips for Installing on Linux Fedora 19

homepage Forums BridgePoint/xtUML Usage and Training Tips for Installing on Linux Fedora 19

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
  • #1281

    1) Tried to run installer. It failed with:

    [code title=””]bash: ./xtUMLEditor_v4.1.2.ixl: /lib/ bad ELF interpreter: No such file or directory[/code]

    This appears to be a library compatibility problem. I knew I would want wine
    eventually anyway, and thought installing it may pull in the libs I need. So I did:

    [code title=””]$ sudo yum install wine
    $ sudo yum install gcc-c++[/code]

    And let it pull in all the dependencies it wanted to. After the wine install completed, the
    installer runs OK, but the installation is still not correct.

    2) The post-install log (in ~/mgc/install.ixl/LOGS/) indicated failure running dos2unix, so:

    [code title=””]$ sudo yum install dos2unix[/code]

    and re-run the the installer. Now the install was good.

    3) However, when I ran, nothing happens. Looked at log (in ~/MentorGraphics/xtUMLEditor/eclipse/configuration)
    and see a SWT/gtk library error. So:

    [code title=””]$ sudo yum install compat-libstdc++-33
    $ sudo yum install gtk2.i686[/code]

    xtUML Editor now starts properly.

    Bob Mulvey

    BridgePoint now has a developer’s guide that focuses on ubuntu. There is a FAQ that describes linux package-specifIc installation issues (as well as Windows). The Developer’s Getting started will point you to the FAQ,but here are inks:
    Developer’s Getting Started:

Viewing 2 posts - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.